"Error response from daemon: client version 1.25 is too old"
Author: KopfKriegCreated Nov 14, 2025Updated Dec 12, 2025
LabelsType: BugPriority: MediumStatus: Available
Describe the bug
I have two server (Ubuntu 22.04 LTS and Ubuntu 24.04 LTS), both running Docker v29.0.0.
Both are unable to run watchtower, because the run into a loop with the following error message:
watchtower | time="2025-11-14T02:39:36+01:00" level=error msg="Error response from daemon: client version 1.25 is too old. Minimum supported API version is 1.44, please upgrade your client to a newer version"
watchtower | time="2025-11-14T02:39:36+01:00" level=info msg="Waiting for the notification goroutine to finish" notify=no
watchtower exited with code 1 (restarting)Had to stop both watchtower instances and not sure what to do. Everything is up to date already.
Steps to reproduce
- Install Ubuntu 22.04 or 24.04 LTS
- Install Docker from docker.com
- Run watchtower from containrrr/watchtower:latest
- Enjoy the error messages and notification spam (if configured)
Expected behavior
It should work as before, running in the background, updating containers as expected.
Screenshots
No response
Environment
- Platform: Ubuntu 22.04 LTS & Ubuntu 24.04 LTS
- Architecture: x86_64
- Docker Version: 29.0.0
Your logs
[…]
watchtower | time="2025-11-14T02:44:37+01:00" level=debug msg="Sleeping for a second to ensure the docker api client has been properly initialized."
watchtower | time="2025-11-14T02:44:38+01:00" level=debug msg="Making sure everything is sane before starting"
watchtower | time="2025-11-14T02:44:38+01:00" level=debug msg="Retrieving running containers"
watchtower | time="2025-11-14T02:44:38+01:00" level=error msg="Error response from daemon: client version 1.25 is too old. Minimum supported API version is 1.44, please upgrade your client to a newer version"
watchtower | time="2025-11-14T02:44:38+01:00" level=info msg="Waiting for the notification goroutine to finish" notify=no
watchtower exited with code 1 (restarting)
watchtower | time="2025-11-14T02:44:39+01:00" level=debug msg="Sleeping for a second to ensure the docker api client has been properly initialized."
Gracefully Stopping... press Ctrl+C again to force
Container watchtower Stopping
Container watchtower StoppedAdditional context
No response
Source: containrrr/watchtower