#5014·opik

[Bug]: Table default.DATABASECHANGELOG does not exist. Maybe you meant default.DATABASECHANGELOG1

Author: ec2ainunCreated Feb 1, 2026Updated Sep 17, 2026
LabelsJC

What component(s) are affected?

  • Opik Python SDK
  • Opik Typescript SDK
  • Opik Agent Optimizer SDK
  • Opik UI
  • Opik Server
  • Documentation

Opik version

  • Opik version: 1.10.1

Describe the problem

setup using local infra docker compose, always got issue on clickhouse Migration failed for changeset liquibase/db-app-analytics/migrations/000017_change_tables_to_replicated.sql::change-tables-to-replicated-20::liyaka:

Reproduction steps and code snippets

https://github.com/comet-ml/opik/blob/85a898ec40924988cd49ec85025624f1885d7625/apps/opik-backend/src/main/resources/liquibase/db-app-analytics/migrations/000017_change_tables_to_replicated.sql#L287

Error logs or stack trace

liquibase.exception.CommandExecutionException: liquibase.exception.LiquibaseException: liquibase.exception.MigrationFailedException: Migration failed for changeset liquibase/db-app-analytics/migrations/000017_change_tables_to_replicated.sql::change-tables-to-replicated-20::liyaka: Reason: liquibase.exception.DatabaseException: ClickHouse exception, code: 1002, host: 192.168.0.92, port: 40024; Code: 60. DB::Exception: Table default.DATABASECHANGELOG does not exist. Maybe you meant default.DATABASECHANGELOG1?. (UNKNOWN_TABLE) (version 25.10.1.3832 (official build)) [Failed SQL: (1002) ALTER TABLE default.DATABASECHANGELOG1 ATTACH PARTITION tuple() FROM default.DATABASECHANGELOG] at liquibase.command.CommandScope.lambda$execute$6(CommandScope.java:310) at liquibase.Scope.child(Scope.java:225) at liquibase.Scope.child(Scope.java:201) at liquibase.command.CommandScope.execute(CommandScope.java:251) at liquibase.Liquibase.lambda$update$0(Liquibase.java:216) at liquibase.Scope.lambda$child$0(Scope.java:216) at liquibase.Scope.child(Scope.java:225) at liquibase.Scope.child(Scope.java:215) at liquibase.Scope.child(Scope.java:194) at liquibase.Liquibase.runInScope(Liquibase.java:1366) at liquibase.Liquibase.update(Liquibase.java:205) at liquibase.Liquibase.update(Liquibase.java:188) at liquibase.Liquibase.update(Liquibase.java:175) at liquibase.Liquibase.update(Liquibase.java:165) at io.dropwizard.migrations.DbMigrateCommand.run(DbMigrateCommand.java:66) at io.dropwizard.migrations.DbCommand.run(DbCommand.java:70) at io.dropwizard.migrations.AbstractLiquibaseCommand.run(AbstractLiquibaseCommand.java:82) at io.dropwizard.core.cli.ConfiguredCommand.run(ConfiguredCommand.java:98) at io.dropwizard.core.cli.Cli.run(Cli.java:78) at io.dropwizard.core.Application.run(Application.java:94) at com.comet.opik.OpikApplication.main(OpikApplication.java:68) Caused by: liquibase.exception.LiquibaseException: liquibase.exception.MigrationFailedException: Migration failed for changeset liquibase/db-app-analytics/migrations/000017_change_tables_to_replicated.sql::change-tables-to-replicated-20::liyaka:

Healthcheck results

No response