[Deployment Issue] Can not start caprover
Author: skliarieCreated Feb 17, 2026Updated Jun 18, 2026
Labelsdeployment-issue
I am trying to run caprover in environment without direct internet access. I already use 'MAIN_NODE_IP_ADDRESS=127.0.0.1' env variable
We use JFrog Artifactory as "proxy" for docker images download. Thus any docker image we want to download must have special URL ("prefix"). For example, to download caprover image I used this:
docker pull artifactory.internal.domain/docker-virtual/caprover/caprover
When caprover starts, it tries to download nginx directly that is not possible. It fails with this error:
Pulling: nginx:1.27.2
Installation failed.
Error: (HTTP code 500) server error - failed to resolve reference "docker.io/library/nginx:1.27.2": failed to do request: Head "https://registry-1.docker.io/v2/library/nginx/manifests/1.27.2": dial tcp: lookup registry-1.docker.io on 127.0.0.53:53: read udp 127.0.0.1:58635->127.0.0.53:53: i/o timeoutHow can I let it know the internal URL for the nginx image?
Source: caprover/caprover