Baike.dev
All toolsAI codingTrendingOpen sourceNewsSubmit
Log in
Back to tool/Back to issues
#1883·caprover

How to deploy image already present in the same caprover's host? No registry needed

Author: frederikhorsCreated Sep 15, 2023Updated May 13, 2026
Labelsdeployment-issue

I'm using v1.11.0 and I'm building the image on the host where caprover runs.

So if I run docker images:

REPOSITORY                           TAG       IMAGE ID       CREATED          SIZE
my-amazing-image/web                 latest    1a52ecfad863   13 minutes ago   211MB

So I would like to deploy this image WITHOUT any registry.

I'm trying with deploy method 6 (or with caprover deploy --imageName ...) using:

my-amazing-image/web:latest

and the error is:

------------------------- Fri Sep 15 2023 22:09:25 GMT+0000 (Coordinated Universal Time)
Build started for app-name
An explicit image name was provided (my-amazing-image/web:latest). Therefore, no build process is needed.
Pulling this image: my-amazing-image/web:latest This process might take a few minutes.
Build has failed!
----------------------
Deploy failed!
Error: (HTTP code 404) unexpected - pull access denied for my-amazing-image/web, repository does not exist or may require 'docker login': denied: requested access to the resource is denied

If I use deploy method 4 writing this:

FROM my-amazing-image/web:latest

it works!

Why?

I would like to use the CLI command caprover deploy --imageName my-amazing-image/web:latest.

Source: caprover/caprover

View original on GitHubView discussion on GitHub