Multipass can't bind on the port for listenning after successfull installation on Windows 11 Pro
Describe the bug Multipass can't bind on the port for listening after successful installation on Windows 11 Pro
To Reproduce It is only reproduced on the several machines of the students Expected behavior What did you expect to happen?
Logs & "C:\Program Files\Multipass\bin\multipassd.exe" --verbosity debug ... WARNING: All log messages before absl::InitializeLog() is called are written to STDERR E0000 00:00:1771579936.622526 12352 chttp2_server.cc:1177] UNKNOWN:No address added out of total 2 resolved for 'localhost:50052' {created_time:"2026-02-20T09:32:16.6225103+00:00", children:[UNKNOWN:Failed to prepare server socket {fd:916, created_time:"2026-02-20T09:32:16.6224115+00:00", children:[UNAVAILABLE:bind: Permission denied (An attempt was made to access a socket in a way forbidden by its access permissions. -- 10013) {created_time:"2026-02-20T09:32:16.6223602+00:00", grpc_status:14}]}, UNKNOWN:Failed to prepare server socket {created_time:"2026-02-20T09:32:16.6224866+00:00", fd:916, children:[UNAVAILABLE:bind: Permission denied (An attempt was made to access a socket in a way forbidden by its access permissions. -- 10013) {grpc_status:14, created_time:"2026-02-20T09:32:16.6224853+00:00"}]}]} error: Failed to start multipass gRPC service at localhost:50052.
Additional info
- OS: Windows 11 Pro
- CPU architecture or model: AMD64
- version: 1.15.0
Additional context It seems that the problem is that some components of Windows (Hyper-V) can reserve ports which we can get using:
netsh interface ipv4 show excludedportrange protocol=tcpWe could start a multipass service listening on a different port. It could be assumed that to fix this, your installation script should check whether your default port is already reserved and reconfigure the server-side (Windows service) and client (cli) to work on a different port.
Source: canonical/multipass