uuid macro fails atlas schema lint
Author: electricalCreated Aug 4, 2026Updated Aug 12, 2026
Hi,
We have a table definition like below:
CREATE TABLE IF NOT EXISTS ourtable (
series_id LowCardinality(String),
period_month UInt32,
refreshed_at DateTime64(3, 'UTC')
)
ENGINE = ReplicatedReplacingMergeTree(
'/clickhouse/tables/{cluster}/{shard}/{uuid}',
'{replica}',
refreshed_at
)
PARTITION BY intDiv(period_month, 100)
ORDER BY (series_id, period_month)
SETTINGS index_granularity = 8192;The lint action fails with the following:
Error: schema/transnetbw_aggregations.sql:52: code: 36, message: Macro 'uuid' in engine arguments is only supported when the UUID is explicitly specified, used within an ON CLUSTER query, or when using the Replicated database engineAs you can see we use the Replicated table engine ( not the DB engine ), and we use the ON CLUSTER statements when applying and on diff. For the diff action we have:
diff "clickhouse" {
cluster {
name = "main"
}
}But that same block doesn't seem to work for the lint part.
What can we do to solve this?
Source: ariga/atlas