#403·k3sup

Support request for SSH configuration

Author: flatironnycCreated Mar 23, 2023Updated Jan 29, 2024
Labelsquestionsupport

I tried the perform the following:

k3sup join --ip 192.168.1.217 --server-ip 192.168.1.199 --user suhr

got the error: Error: unable to connect to (server) 192.168.1.199:22 over ssh: ssh: handshake failed: ssh: unable to authenticate, attempted methods [none publickey], no supported methods remain

on the server, I see that: Mar 23 01:03:15 suhr-dt sshd[13518]: Connection closed by authenticating user suhr 192.168.1.217 port 39384 [preauth]

Why do you need this?

Just trying to set up k3s for learning purpose.

Expected Behaviour

I expect this to create an agent and connect to server

Current Behaviour

It complains about some ssh error

Possible Solution

Steps to Reproduce

Your Environment

server is kubuntu 20.04 on x86_64; trying to connect from Raspberry pi4

  • k3sup version:
k3sup version
  • What Kubernetes distribution, client and server version are you using?
bash
kubectl version
  • What OS or type or VM are you using for your cluster? Where is it hosted? (for k3sup install/join):

  • Operating System and version (e.g. Linux, Windows, MacOS):

uname -a

cat /etc/os-release

Do you want to work on this?

Subject to design approval, are you willing to work on a Pull Request for this issue or feature request?

  • Yes
  • No