Domain specific upstream servers going through fallback servers

Author: Linx-ESPCreated Sep 12, 2026Updated Sep 17, 2026
LabelsbugPriority: P4

Prerequisites

Platform (OS and CPU architecture)

Linux, AMD64 (aka x86_64)

Installation

Docker

Setup

On one machine

AdGuard Home version

v0.107.79

Action

I have adguard set so domain "lan" uses upstream "10.x.x.1". "lan" domain is given by dhcp and I want it resolved by the router that does DHCP.
There is the "wpad.lan" domain windows (probably more) stuff uses for web proxy autodiscovery.
I have it not setup so it should go nowhere.
Probably happens with more "hostnames.lan"

Expected result

"wpad.lan" gets a nxdomain or whatever from the 10.x.x.1 upstream.
If it fails it fails but doesn't go upstream elsewhere

Actual result

At least "wpad.lan", and maybe all of the ".lan" or the ones that my router doesn't respond go to the fallback servers

Additional information and/or screenshots

Relevant probably: https://github.com/AdguardTeam/AdGuardHome/issues/7931