[Error] doesnt work anything rarely works
Ubuntu 24.04 kng@kng-latitude7420:~$ distrobox -v Error: invalid command distrobox version: 1.7.0
Choose one of the available commands: assemble create enter list | ls rm stop upgrade ephemeral generate-entry version help
kng@kng-latitude7420:~$ distrobox create ubuntu --image ubuntu:latest --home ~/distrobox/ubuntulatest Image ubuntu:latest not found. Do you want to pull the image now? [Y/n]: Y Resolved "ubuntu" as an alias (/etc/containers/registries.conf.d/shortnames.conf) Trying to pull docker.io/library/ubuntu:latest... Getting image source signatures Copying blob f3db1cd94078 done | Copying blob 06e9d71331fb done | Copying config af52039db3 done | Writing manifest to image destination af52039db3f8df8b54cd80945bdabea797445f414955027fa0bed9cd3908244b Creating 'ubuntu' using image ubuntu:latest [ OK ] Distrobox 'ubuntu' successfully created. To enter, run:
distrobox enter ubuntu
kng@kng-latitude7420:~$ distrobox enter ubuntu Starting container... [ OK ] Installing basic packages... [ OK ] Setting up devpts mounts... [ OK ] Setting up read-only mounts... [ OK ] Setting up read-write mounts... [ OK ] Setting up host's sockets integration... [ OK ] Integrating host's themes, icons, fonts... [ OK ] Setting up package manager exceptions... [ OK ] Setting up package manager hooks... [ OK ] Setting up dpkg exceptions... [ OK ] Setting up apt hooks... [ OK ] Setting up distrobox profile... [ OK ] Setting up sudo... [ OK ] Setting up user groups... [ OK ] Setting up kerberos integration... [ OK ] Setting up user's group list... [ OK ] Setting up existing user... [ OK ] Setting up user home... [ OK ] Ensuring user's access... [ OK ] Setting up skel... [ OK ]
Container Setup Complete! kng@ubuntu:/home/kng$ as^C kng@ubuntu:/home/kng$ ^C kng@ubuntu:/home/kng$ ^C kng@ubuntu:/home/kng$ ^C kng@ubuntu:/home/kng$ ^C kng@ubuntu:/home/kng$ ^C kng@ubuntu:/home/kng$ history 1 ls 2 history kng@ubuntu:/home/kng$ ls^C kng@ubuntu:/home/kng$ logout kng@kng-latitude7420:~$ distrobox create fedora --image fedora:latest --home ~/distrobox/fedoralatest Image fedora:latest not found. Do you want to pull the image now? [Y/n]: y Resolved "fedora" as an alias (/etc/containers/registries.conf.d/shortnames.conf) Trying to pull registry.fedoraproject.org/fedora:latest... Getting image source signatures Copying blob a5f191eea5f3 done | Copying config 596ef680df done | Writing manifest to image destination 596ef680dfe18941e6cf686f4abcab044d5d8d5f992e3558062b8fbc2015266a Creating 'fedora' using image fedora:latest [ OK ] Distrobox 'fedora' successfully created. To enter, run:
distrobox enter fedora
kng@kng-latitude7420:~$ distrobox create fedora --image fedora:45 --home ~/distrobox/fedoralatest Distrobox named 'fedora' already exists. To enter, run:
distrobox enter fedora
kng@kng-latitude7420:$ distrobox enter fedora
Starting container... [ OK ]
Installing basic packages... [ OK ]
Setting up devpts mounts... [ OK ]
Setting up read-only mounts... [ OK ]
Setting up read-write mounts... [ OK ]
Setting up host's sockets integration... [ OK ]
Integrating host's themes, icons, fonts... [ OK ]
Setting up package manager exceptions... [ OK ]
Setting up rpm exceptions... [ OK ]
Setting up distrobox profile... [ OK ]
Setting up sudo... [ OK ]
Setting up user groups... [ OK ]
Setting up kerberos integration... [ OK ]
Setting up user's group list... [ OK ]
Setting up existing user... [ OK ]
Setting up user home... [ OK ]
Ensuring user's access... Error: An error occurred
kng@kng-latitude7420:$ distrobox create fedora44 --image fedora:44 --home ~/distrobox/fedora44
Image fedora:44 not found.
Do you want to pull the image now? [Y/n]: Y
Resolved "fedora" as an alias (/etc/containers/registries.conf.d/shortnames.conf)
Trying to pull registry.fedoraproject.org/fedora:44...
Getting image source signatures
Copying blob a5f191eea5f3 skipped: already exists
Copying config 596ef680df done |
Writing manifest to image destination
596ef680dfe18941e6cf686f4abcab044d5d8d5f992e3558062b8fbc2015266a
Creating 'fedora44' using image fedora:44 [ OK ]
Distrobox 'fedora44' successfully created.
To enter, run:
distrobox enter fedora44
kng@kng-latitude7420:$ distrobox enter
/dev org.opencontainers.image.title:ubuntu
/dev/ptmx org.opencontainers.image.version:26.04][/run/user/1000
/dev/pts] /run/host
/etc/hosts /sys
/etc/resolv.conf /tmp
fedora ubuntu
fedora44 /usr/bin/distrobox-export
/home/kng /usr/bin/distrobox-host-exec
/home/kng/distrobox/ubuntulatest /usr/bin/entrypoint
kali /var/log/journal
kng@kng-latitude7420:$ distrobox enter fedora
fedora fedora44
kng@kng-latitude7420:$ distrobox enter fedora44
Starting container... [ OK ]
Installing basic packages... [ OK ]
Setting up devpts mounts... [ OK ]
Setting up read-only mounts... [ OK ]
Setting up read-write mounts... [ OK ]
Setting up host's sockets integration... [ OK ]
Integrating host's themes, icons, fonts... [ OK ]
Setting up package manager exceptions... [ OK ]
Setting up rpm exceptions... [ OK ]
Setting up distrobox profile... [ OK ]
Setting up sudo... [ OK ]
Setting up user groups... [ OK ]
Setting up kerberos integration... [ OK ]
Setting up user's group list... [ OK ]
Setting up existing user... [ OK ]
Setting up user home... [ OK ]
Ensuring user's access... Error: An error occurred
kng@kng-latitude7420:$ distrobox create fedora44b --image fedora:44
Creating 'fedora44b' using image fedora:44 [ OK ]
Distrobox 'fedora44b' successfully created.
To enter, run:
distrobox enter fedora44b
kng@kng-latitude7420:$ distrobox enter fedora44
fedora44 fedora44b
kng@kng-latitude7420:$ distrobox enter fedora44b
Starting container... [ OK ]
Installing basic packages... [ OK ]
Setting up devpts mounts... [ OK ]
Setting up read-only mounts... [ OK ]
Setting up read-write mounts... [ OK ]
Setting up host's sockets integration... [ OK ]
Integrating host's themes, icons, fonts... [ OK ]
Setting up package manager exceptions... [ OK ]
Setting up rpm exceptions... [ OK ]
Setting up distrobox profile... [ OK ]
Setting up sudo... [ OK ]
Setting up user groups... [ OK ]
Setting up kerberos integration... [ OK ]
Setting up user's group list... [ OK ]
Setting up existing user... [ OK ]
Setting up user home... [ OK ]
Ensuring user's access... Error: An error occurred
kng@kng-latitude7420:~$ distrobox -v
Error: invalid command
distrobox version: 1.7.0
Choose one of the available commands: assemble create enter list | ls rm stop upgrade ephemeral generate-entry version help
kng@kng-latitude7420:$ distrobox create fedora44b --image fedora:44^C$ ^C
kng@kng-latitude7420:
kng@kng-latitude7420:$ ^C$ ^C
kng@kng-latitude7420:
kng@kng-latitude7420:$ nano tmuxxxxx.txt$ distrobox enter ubuntu
kng@kng-latitude7420:
kng@ubuntu:/home/kng$
logout
kng@kng-latitude7420:$ distrobox enter fedora44b$ distrobox create fedora36 --image fedora:36
Image fedora:36 not found.
Do you want to pull the image now? [Y/n]: Y
Resolved "fedora" as an alias (/etc/containers/registries.conf.d/shortnames.conf)
Trying to pull registry.fedoraproject.org/fedora:36...
Getting image source signatures
Copying blob 61f339d02474 done |
Copying config cfd4c24958 done |
Writing manifest to image destination
cfd4c2495877ddf1d551bb9b8e7d31a6525097d6cc5d3a798c95c62a65266404
Creating 'fedora36' using image fedora:36 [ OK ]
Distrobox 'fedora36' successfully created.
To enter, run:
Starting container... [ OK ]
Installing basic packages... [ OK ]
Setting up devpts mounts... [ OK ]
Setting up read-only mounts... [ OK ]
Setting up read-write mounts... [ OK ]
Setting up host's sockets integration... [ OK ]
Integrating host's themes, icons, fonts... [ OK ]
Setting up package manager exceptions... [ OK ]
Setting up rpm exceptions... [ OK ]
Setting up distrobox profile... [ OK ]
Setting up sudo... [ OK ]
Setting up user groups... [ OK ]
Setting up kerberos integration... [ OK ]
Setting up user's group list... [ OK ]
Setting up existing user... [ OK ]
Setting up user home... [ OK ]
Ensuring user's access... Error: An error occurred
kng@kng-latitude7420:
distrobox enter fedora36
kng@kng-latitude7420:~$ distrobox enter fedora36 Starting container... [ OK ] Installing basic packages... [ OK ] Setting up devpts mounts... [ OK ] Setting up read-only mounts... [ OK ] Setting up read-write mounts... [ OK ] Setting up host's sockets integration... [ OK ] Integrating host's themes, icons, fonts... [ OK ] Setting up package manager exceptions... [ OK ] Setting up rpm exceptions... [ OK ] Setting up distrobox profile... [ OK ] Setting up sudo... [ OK ] Setting up user groups... [ OK ] Setting up kerberos integration... [ OK ] Setting up user's group list... [ OK ] Setting up existing user... [ OK ] Setting up user home... [ OK ] Ensuring user's access... [ OK ]
Container Setup Complete!
kng@fedora36:$ ^C
kng@fedora36:$
logout
kng@kng-latitude7420:~$ distrobox create fedora36b --image fedora:36 --home ~/distrobox/fedora36b
Creating 'fedora36b' using image fedora:36 [ OK ]
Distrobox 'fedora36b' successfully created.
To enter, run:
distrobox enter fedora36b
kng@kng-latitude7420:~$ distrobox enter fedora36b Starting container... [ OK ] Installing basic packages... [ OK ] Setting up devpts mounts... [ OK ] Setting up read-only mounts... [ OK ] Setting up read-write mounts... [ OK ] Setting up host's sockets integration... [ OK ] Integrating host's themes, icons, fonts... [ OK ] Setting up package manager exceptions... [ OK ] Setting up rpm exceptions... [ OK ] Setting up distrobox profile... [ OK ] Setting up sudo... [ OK ] Setting up user groups... [ OK ] Setting up kerberos integration... [ OK ] Setting up user's group list... [ OK ] Setting up existing user... [ OK ] Setting up user home... [ OK ] Ensuring user's access... [ OK ] Setting up skel... [ OK ]
Container Setup Complete!
[kng@fedora36b kng]$ ^C
[kng@fedora36b kng]$
logout
kng@kng-latitude7420:$ distrobox enter fedora36
kng@fedora36:$
logout
kng@kng-latitude7420:~$
kng@kng-latitude7420:~$ distrobox create kali123 --image kali-rolling:latest Image kali-rolling:latest not found. Do you want to pull the image now? [Y/n]: y Resolved "kali-rolling" as an alias (/etc/containers/registries.conf.d/shortnames.conf) Trying to pull docker.io/kalilinux/kali-rolling:latest... Getting image source signatures Copying blob 63bb00c568d1 done | Copying config 30f6cf697c done | Writing manifest to image destination 30f6cf697c6beb99b3058e4c7702311677fb69002976645304da5756a1bc83fc Creating 'kali123' using image kali-rolling:latest [ OK ] Distrobox 'kali123' successfully created. To enter, run:
distrobox enter kali123
Warning: Distribution not found in default icon set. Defaulting to generic one. kng@kng-latitude7420:~$ distrobox enter kali123 Starting container... [ OK ] Installing basic packages... Error: An error occurred
kng@kng-latitude7420:$ distrobox-list$ distrobox-stop all
Do you really want to stop all? [Y/n]: Y
Error: no container with name or ID "all" found: no such container
kng@kng-latitude7420:
ID | NAME | STATUS | IMAGE
1c29b1abe191 | kali | Exited (1) 3 hours ago | docker.io/kalilinux/kali-last-release:latest
52ca1575af21 | ubuntu | Up 3 hours | docker.io/library/ubuntu:latest
org.opencon | org.opencontainers.image.title:ubuntu org.opencontainers.image.version:26.04][/run/user/1000 /etc/hosts /usr/bin/distrobox-export /usr/bin/distrobox-host-exec /home/kng /dev/ptmx /etc/resolv.conf /sys /home/kng/distrobox
/ubuntulatest /dev /run/host /tmp /usr/bin/entrypoint /var/log/journal /dev/pts] | org.opencontainers.image.title:ubuntu org.opencontainers.image.version:26.04][/run/user/1000 /etc/hosts /usr/bin/distrobox-export /usr/bin/distrobox-hos
t-exec /home/kng /dev/ptmx /etc/resolv.conf /sys /home/kng/distrobox/ubuntulatest /dev /run/host /tmp /usr/bin/entrypoint /var/log/journal /dev/pts] | org.opencontainers.image.title:ubuntu org.opencontainers.image.version:26.04][/run/u
ser/1000 /etc/hosts /usr/bin/distrobox-export /usr/bin/distrobox-host-exec /home/kng /dev/ptmx /etc/resolv.conf /sys /home/kng/distrobox/ubuntulatest /dev /run/host /tmp /usr/bin/entrypoint /var/log/journal /dev/pts]
01f526634847 | fedora | Exited (1) 3 hours ago | registry.fedoraproject.org/fedora:latest
6ac90509c3b1 | fedora44 | Exited (1) 3 hours ago | registry.fedoraproject.org/fedora:44
1ca927160c8f | fedora44b | Exited (1) 2 hours ago | registry.fedoraproject.org/fedora:44
8ff7c15c858c | fedora36 | Up 2 hours | registry.fedoraproject.org/fedora:36
6dfd7905f280 | fedora36b | Up 2 hours | registry.fedoraproject.org/fedora:36
3181d038941f | kali123 | Exited (100) 2 hours ago | docker.io/kalilinux/kali-rolling:latest
kng@kng-latitude7420:$ distrobox-stop -a
Do you really want to stop kali ubuntu org.opencontainers.image.title:ubuntuorg.opencontainers.image.version:26.04][/run/user/1000/etc/hosts/usr/bin/distrobox-export/usr/bin/distrobox-host-exec/home/kng/dev/ptmx/etc/resolv.conf/sys/home/kng/distrobox/ubuntulatest/dev/run/host/tmp/usr/bin/entrypoint/var/log/journal/dev/pts] fedora fedora44 fedora44b fedora36 fedora36b kali123 ? [Y/n]: Y
kali
ubuntu
Error: no container with name or ID "org.opencontainers.image.title:ubuntuorg.opencontainers.image.version:26.04][/run/user/1000/etc/hosts/usr/bin/distrobox-export/usr/bin/distrobox-host-exec/home/kng/dev/ptmx/etc/resolv.conf/sys/home/kng/distrobox/ubuntulatest/dev/run/host/tmp/usr/bin/entrypoint/var/log/journal/dev/pts]" found: no such container
kng@kng-latitude7420:$ distrobox-list
ID | NAME | STATUS | IMAGE
1c29b1abe191 | kali | Exited (1) 4 hours ago | docker.io/kalilinux/kali-last-release:latest
52ca1575af21 | ubuntu | Exited (143) 16 seconds ago | docker.io/library/ubuntu:latest
org.opencon | org.opencontainers.image.title:ubuntu org.opencontainers.image.version:26.04][/run/user/1000 /etc/hosts /usr/bin/distrobox-export /usr/bin/distrobox-host-exec /home/kng /dev/ptmx /etc/resolv.conf /sys /home/kng/distrobox/ubuntulatest /dev /run/host /tmp /usr/bin/entrypoint /var/log/journal /dev/pts] | org.opencontainers.image.title:ubuntu org.opencontainers.image.version:26.04][/run/user/1000 /etc/hosts /usr/bin/distrobox-export /usr/bin/distrobox-host-exec /home/kng /dev/ptmx /etc/resolv.conf /sys /home/kng/distrobox/ubuntulatest /dev /run/host /tmp /usr/bin/entrypoint /var/log/journal /dev/pts] | org.opencontainers.image.title:ubuntu org.opencontainers.image.version:26.04][/run/user/1000 /etc/hosts /usr/bin/distrobox-export /usr/bin/distrobox-host-exec /home/kng /dev/ptmx /etc/resolv.conf /sys /home/kng/distrobox/ubuntulatest /dev /run/host /tmp /usr/bin/entrypoint /var/log/journal /dev/pts]
01f526634847 | fedora | Exited (1) 4 hours ago | registry.fedoraproject.org/fedora:latest
6ac90509c3b1 | fedora44 | Exited (1) 4 hours ago | registry.fedoraproject.org/fedora:44
1ca927160c8f | fedora44b | Exited (1) 3 hours ago | registry.fedoraproject.org/fedora:44
8ff7c15c858c | fedora36 | Up 3 hours | registry.fedoraproject.org/fedo
Source: 89luca89/distrobox