#13837·1Panel

[Bug] Website settings interfere with each other, causing configuration loss

Author: PosiedChossCreated Sep 16, 2026Updated Sep 17, 2026
Labelstype: question

Contact Information

凌霞 News12 白青森

1Panel Version

专业版 v2.3.0

Problem Description

某天,我的网站证书过期了 正好想要把allinssl更换成1panel自带的证书管理 虽然经历了一顿折腾,我其实想反馈很多问题,包括但不限于

  • 在面板设置里设置代理,但是代理不能直接测试是否可用
  • 打开OpenResty的设置页面,当前状态处报错“服务错误: Get "http://127.0.0.1/nginx_status": EOF”
  • 证书申请的过程中无法手动中断,不小心填错想要编辑/删除还得等任务结束(1panel里几乎大部分任务都是如此,只给看日志,不让提供终止的操作)
  • 同时申请多个证书的任务必须走完一个才能到下一个(或许这不算什么问题,但我要等很久) 最后就是我想要提出的本issues的主题: 我在证书过期后,从网站具体的设置的“HTTPS”项,取消了https,然后从证书管理为网站申请了新的证书,但是我发现无论如何,访问都是提示“ERR_SSL_PROTOCOL_ERROR” 我打开配置文件仔细观看,一时半会也没找到什么问题所在,一切都很正常 折腾了将近两个晚上,发现是因为我在”真实IP“里打开了IP来源,并且设置是其他“proxy_protocol” 这个操作会在配置文件里的listen 443 ssl; 后面添加一个 “proxy_protocol” 最终的配置应该是 listen 443 ssl proxy_protocol; 而因为我针对https的相关按钮调整,导致了配置变成了listen 443 ssl; 导致访问网页时出现了ERR_SSL_PROTOCOL_ERROR

Steps to Reproduce

证书过期,于是从设置中手动关闭取消了HTTPS

Image

申请了新的证书

Image

可能是因为手动关闭行为,新申请的证书即使是勾选网站的申请操作,但也没有自动部署,于是手动又打开了HTTPS

Image 并且选择了正确的证书,此时网站配置如下Image

之后访问就一直出现ERR_SSL_PROTOCOL_ERROR

Image

经过不断的折腾,终于发现关闭真实IP开关可以解决问题,仔细想了一下 我设置的是proxy_protocol 这会在SSL的后面添加一个proxy_protocol,于是手动加上

Image

如此便访问成功了!

The expected correct result

我全程只在解决问题的时候才添加了proxy_protocol,大部分时间都没动配置文件 应该针对proxy_protocol的配置,在HTTPS打开时自动添加该后缀

Related log output

bash

Additional Information

No response